Home / Networking / Load Balance & Failover Mikrotik Dengan PCC

Load Balance & Failover Mikrotik Dengan PCC

Menjelang siang di bulan ramadhan semoga masih pada kuat, kali ini gw akan mencatat soal load balance dan fail over 2 metode yang cukup nyaman digunakan untuk zero downtime, hope soo!!!

Kita pasti banyak tau mengenai metode load balance pada mikrotik diantaranya ada metode bonding, metode bandwidth based dan yang satu ini dengan menggunakan PCC (Per Connection Classifier)

Seperti kita ketahui load balance digunakan untuk menggabungkan (membagi rata) 2 koneksi dari ISP yang berbeda agar lebih bermanfaat yang jelas, jadi bisa sedikit ngebut dan ndak kerasa klo bandwidth sedang dibatasi, bagi sebagian orang ini kagak penting alias buat apa broo??? ya ya ya gw dah tau situ juragan bandwidth

Tapi buat gw ini salah satu metode yang cukup enjoy buat nambahin speed internet dikala badai dan hujan melanda disaat titik sinar (heyyy youuu) fokus fokus…

Lalu apa gunanya failover? Makanan yang satu ini merupakan bumbu ketika salah satu ISP kita down, sehingga kita masih bisa menggunakan ISP lain tanpa terasa karena auto namun sayangnya akan terasa degradasi bandwidth jika selama ini kita menggunakan full traffic bw nya.

ok daripada makin nulis yang ndak jelas gw mulai, siapkan setidaknya 2 koneksi ISP sebuah mikrotik dan juga ritual doa agar ilmunya bermanfaat.

Kurang lebih seperti ini lah topology nya, mari kita configure step by step nya

Setup IP Address

Setup IP Address

/ip address
add address=192.168.0.2/24 interface=ether1 network=192.168.0.0 (ISP1)
add address=192.168.5.2/24 interface=ether2 network=192.168.5.0 (ISP2)
add address=192.168.22.1/24 interface=ether3 network=192.168.22.0 (Lokal)

Nah yang satu ini akan menentukan alur keluar masuk koneksi dan juga pemisahan load balancer nya

SetupMangle

SetupMangle

/ip firewall mangle
add action=mark-connection chain=input in-interface=ether1 new-connection-mark=WAN1_conn
add action=mark-connection chain=input in-interface=ether2 new-connection-mark=WAN2_conn
add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1 add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2 add chain=prerouting dst-address=192.168.0.2/24 in-interface=ether3 action=accept
add chain=prerouting dst-address=192.168.5.2/24 in-interface=ether3 action=accept
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=ether3 new-connection-mark=WAN1_conn per-connection-classifier=both-addresses-and-ports:3/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=ether3 new-connection-mark=WAN1_conn per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=ether3 new-connection-mark=WAN2_conn per-connection-classifier=both-addresses-and-ports:3/2
add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=ether3 new-routing-mark=to_WAN1 add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=ether3 new-routing-mark=to_WAN2

Kenapa PCC 3/0 dikarenakan salah satu ISP gw ada jatah lebih 2M dan 1M jadi gw bikin wan1 mendapat jatah 2 kali lebih besar daripada ISP satunya.

Kita lanjut ke routing yang akan menentukan default route dan juga failover nya

SetupRouting

SetupRouting

/ip route
add check-gateway=ping distance=1 gateway=192.168.0.1 routing-mark=to_WAN1
add distance=1 gateway=192.168.5.1 routing-mark=to_WAN2
add distance=1 gateway=192.168.0.1
add distance=2 gateway=192.168.5.1

Yang terakhir adalah NAT supaya bisa jalan keluar

SetupNAT

SetupNAT

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2

Nah test percobaan di router jika memang bisa berjalan 2 ether WAN brrti sudah betul, kemudian coba cek speedtest, taraaaaa anda mendapat bandwidth yang cukupan lahh hehehe.

Ok semoga bermanfaat, keep rock n roll

loading...

About thuekx

Someone want to know much about GOD and Live, and want to share every experience i had, Please click our ads to keep this website alive!!!! Nothing Special About Me, You Can Stop Me But You Can't Stop Us

Leave a Reply

%d bloggers like this: